Support center
Subscribe to updates
Support center
Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Swapcard own Event App, Team, Studio (app.swapcard.com, studio.swapcard.com & team.swapcard.com only) are returning 500 page
Resolved
·
Partial outage
This incident has been resolved.
Fri, Sep 11, 2026, 10:29 AM
(
1
day ago)
·
View all updates
Affected components
Sep 11, 2026, 10:07 AM
10:29 AM
Event App
Studio
Exhibitor Center
Updates
Resolved
This incident has been resolved.
Fri, Sep 11, 2026, 10:29 AM
Investigating
We are currently investigating this issue.
Fri, Sep 11, 2026, 10:07 AM
(
22
minutes earlier)
Swapcard own Event App, Team, Studio (app.swapcard.com, studio.swapcard.com & team.swapcard.com only) are returning 500 page - Swapcard Status